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Goal: Deal with Data Analysis when backed against a wall

Set the stage for dealing with data

State three classes of problems 

Discuss three solutions for each problem

Provide examples for each solution



Best case scenario for statistical analysis 
needs is to consult/collaborate with a 
statistician or statistically-minded 
researcher

Not always possible (funding, location, 
educational situation, etc.)

Take these tools with a grain of salt

Steps in this guide are not mutually 
exclusive
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Create a standardized document of code that is ready for common 
procedures and only needs to be filled in with specifics



Create a standardized document of code that is ready for common 
procedures and only needs to be filled in with specifics

#Simple histogram in ggplot
ggplot(data=DATASET, aes(Y_VAR))+

geom_histogram(bins=6, fill="blue", col="black") 

#Two-sample histogram in ggplot
ggplot(data=DATASET, aes(x=Y_VAR, fill=X_CAT))+

geom_histogram(bins=6, col="black", alpha=0.6, position='identity')+
scale_fill_manual(values=c("red", "blue"))

#Simple boxplot in ggplot
ggplot(data=DATASET, aes(x=X_CAT, y=Y_VAR)) +

geom_boxplot()

#Two-way boxplot in ggplot
ggplot(data=DATASET, aes(x=X_CAT1, y=Y_VAR, fill=X_CAT2)) + 

geom_boxplot()

#Simple scatter plot in ggplot
ggplot(data=DATASET, aes(x=X_NUM, y=Y_VAR)) +

geom_point()

#Two-way scatter plot in ggplot
ggplot(data=DATASET, aes(x=X_NUM, y=Y_VAR, fill=X_CAT, color=X_CAT)) +

geom_point()

#Spaghetti plot in ggplot
ggplot(data=DATASET, aes(x=X_CAT, y=Y_VAR, group=ID)) +

geom_line()

#Logistic regression plot in ggplot
ggplot(data=DATASET, aes(x=X_NUM, y=Y_BIN)) +

geom_point() +
stat_smooth(method="glm", se=FALSE, method.args=list(family=binomial))

#Bubble plot in ggplot
ggplot(data=DATASET, aes(x=X_NUM1, y=Y_VAR, size=X_NUM2))+

geom_point()

#Simple bar plot in ggplot
DATASET_sum<-DATASET %>% 

group_by(X_CAT) %>%       
summarise(mean=mean(Y_VAR),

sd = sd(Y_VAR),
error = qt(0.975,df=n()-1)*sd/sqrt(n()),
ul = mean + error,
ll = mean - error)

ggplot(data=DATASET_sum, aes(x=X_CAT, y=mean, fill=X_CAT)) +
geom_bar(stat="identity") +
geom_errorbar(aes(ymin=ll, ymax=ul), width=0.1)

#Two-way bar plot in ggplot
DATASET_sum<-DATASET %>% 

group_by(X_CAT1, X_CAT2) %>%       
summarise(mean=mean(Y_VAR),

sd = sd(Y_VAR),
error = qt(0.975,df=n()-1)*sd/sqrt(n()),
ul = mean + error,
ll = mean - error)

ggplot(data=DATASET_sum, aes(x=X_CAT1, y=mean)) +
geom_bar(aes(fill=X_CAT2), stat="identity",  
position=position_dodge()) +
geom_errorbar(aes(ymin=ll, ymax=ul, group=tension), width=0.1, 
position=position_dodge(0.9))



Create a standardized document of code that is ready for common 
procedures and only needs to be filled in with specifics

barchart.anova <- function(df, cat_var, num_var) {
cat_var <- enquo(cat_var) 
num_var <- enquo(num_var)
df_sum<-df %>% 

group_by(!!cat_var) %>%       
summarise(mean=mean(!!num_var),

sd = sd(!!num_var),
error = qt(0.975,df=n()-1)*sd/sqrt(n()),
ul = mean + error,
ll = mean - error)

#print(df_sum)
df_plot <<-ggplot(df_sum, aes(!!cat_var, mean, fill=!!cat_var))+

geom_bar(stat="identity", color="black")+
geom_hline(yintercept = 0) +
geom_errorbar(aes(ymin=ll, ymax=ul), width=0.1) +
theme_classic() + theme(legend.position="none") 

}

#Example
barchart.anova(iris, Species, Sepal.Length)
#basic
df_plot
#customized
df_plot + labs(y="Sepal length (cm", x="Species") + 

scale_y_continuous(limits=c(0,7),breaks=c(0:7))+
geom_text(aes(label=c('*','*','*')), vjust=-0.8, size=6)



Use flexible models that can run multiple tests just by tweaking 
parameters, rather than having to run different code for each and every test 

#FLEXIBLE MODELS
head(mtcars)

t.model <-lm(mpg~as.factor(vs), data=mtcars)
summary(t.model)

a.model <-lm(mpg~as.factor(carb), data=mtcars)
summary(a.model)

r.model <-lm(mpg~wt, data=mtcars)
summary(r.model)



Use flexible models that can run multiple tests just by tweaking 
parameters, rather than having to run different code for each and every test 

PROC GLIMMIX data=sashelp.Class;
class Sex;
model Height=Sex /solution dist=normal;
lsmeans Sex /cl;
ods output LSmeans=Class_lsm;

PROC SGPLOT data=Class_lsm;
vbarparm category=Sex response=Estimate/limitupper=Upper 
limitlower=Lower;

PROC GLIMMIX data=sashelp.bweight;
class MomEdLevel;
model Weight=MomEdLevel/solution dist=normal;
lsmeans MomEdLevel / cl;
ods output LSMeans=Bweight_lsm;

PROC SGPLOT data=Bweight_lsm;
vbarparm category=MomEdLevel
response=Estimate/
limitupper=Upper limitlower=Lower;

PROC GLIMMIX data=sashelp.bmimen;
model BMI=age/solution dist=normal;
output out=Bmimen_pred pred lcl ucl;

PROC SGPLOT data=Bmimen_pred;
band x=age lower=lcl upper=ucl;
scatter x=age y=BMI;
series x=age y=Pred;

PROC GLIMMIX data=multicenter;
class center group;
model SideEffect/n = group / solution;
random center; 
lsmeans group / ilink cl;
ods output LSMeans=lsm1;

PROC SGPLOT data=lsm1;
vbarparm category=group 
response=Mu /
limitlower=LowerMu
limitupper=UpperMu;



Use a Graphical Use Interface to rapidly select and run tests
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Use a Graphical Use Interface to rapidly select and run tests

Rcmdr>  summary(AnovaModel.1)
Df Sum Sq Mean Sq F value   Pr(>F)    

feed         5 231129   46226   15.37 5.94e-10 ***
Residuals   65 195556    3009                     
---
Signif. codes:  0 '***' 0.001 '**' 0.01 '*' 0.05 '.' 0.1 ' ' 1

Rcmdr>  with(chickwts, numSummary(weight, groups=feed, statistics=c("mean", "sd")))
mean       sd data:n

casein    323.5833 64.43384     12
horsebean 160.2000 38.62584     10
linseed   218.7500 52.23570     12
meatmeal 276.9091 64.90062     11
soybean   246.4286 54.12907     14
sunflower 328.9167 48.83638     12



Use a Graphical Use Interface to rapidly select and run tests



Start with simplest model design and progressively build from there



Start with simplest model design and progressively build from there

D3_M1 <- lm(DragonHit ~ Arrows.C, 
data=Dragon2)

D3_M2 <- lmer(DragonHit ~ Arrows.C
+ (1|Cathedral), 
data=Dragon2, REML=F)

D3_M3 <- lmer(DragonHit ~ Arrows.C
+ (Arrows.C|Cathedral), 
data=Dragon2, REML=F)



Deploy sheets with quickly available information for statistical methods, 
especially more advanced concepts



 

Examples STATA SPSS Excel SAS R 

Summary statistics Data->Describe Data-> Summary Statistics   

OR 
summarize num_var 

Analyze -> Descriptive 

Statistics -> Descriptives 

=AVERAGE(num_var) 

=MEDIAN(num_var) 
=STDEV.S(num_var) … 
 

PROC UNIVARIATE; 

var num_var; 

summary(num_var) 

Histogram Graphics-> Histogram 
OR 

histogram num_var 

Graphs -> Chart Builder -
> Histogram 

Insert (Charts)-> 
Histogram 

PROC SGPLOT; 
histogram num_var; 

hist(num_var) 

Boxplot Graphics-> Box plot 
OR 

graph box num_var, over(cat_var) 

Graphs -> Chart Builder -
> Boxplot 

Insert (Charts)-> Box 
and Whisker 

PROC SGPLOT; 
vbox num_var/ 
group=cat_var; 

plot(num_var~cat_var) 

Bar plot Graphics-> Bar Chart 
OR 

graph bar (mean) num_var, over(cat_var) 

Graphs -> Chart Builder -
> Bar 

Insert (Charts)-> 
Column 

PROC SGPLOT; 
vbarparm category=cat_var 

treatment=num_mean; 

means <- c(mean_cat1, 
mean_cat2) 

barplot(means) 

Scatterplot Graphics -> Twoway graph 
OR 

twoway (scatter num_var1 num_var2) 

Graphs -> Chart Builder -
> Scatter/Dot 

Insert (Charts)-> 
Scatter 

PROC SGPLOT; 
Scatter y=num_var1 
x=num_var2; 

plot(num_var1, num_var2) 

T-test Statistics -> Summaries, tables, and tests -> 
Classical tests of hypotheses -> t tests 

OR 
ttest num_var, by(cat_var) 

Analyze -> Compare 
means-> Independent-

Samples T Test 

=TTEST(num_var1, 
num_var2, tails, type) 

PROC TTESt; 
var num_var; 

class cat_var; 

t.test(num_var~cat_var) 

ANOVA Statistics-> Linear models and related -> 
ANOVA/MANOVA -> One-way ANOVA 

OR 

oneway num_var cat_var 

Analyze -> Compare 
means-> One-Way 
ANOVA 

Data Analysis (add-on) -
> Anova: Single Factor 

PROC ANOVA; 
class cat_var; 
model num_var=cat_var; 

aov(num_var~cat_var) 

Normal linear 
regression model 

Statistics-> Linear models and related -> 
Linear regression 

OR 
regress num_var1 num_var2 

Analyze -> Regression-> 
Linear 

Data Analysis (add-on) -
> Regression 

PROC REG; 
model num_var1= num_var2; 

lm(num_var1 ~num_var2) 

Logistic regression 

model 

Statistics-> Binary outcomes-> Logistic 

regression 
OR 

logit binary_var num_var 

Analyze -> Regression-> 

Binary Logistic 

N/A PROC LOGISTIC; 

model event/trial= 
num_var2; 

glm(binary_var ~ num_var, 

family=biniomial)  

Poisson regression 
model 

Statistics -> Count outcomes-> Poisson 
regression 

OR 
Poisson count_var num_var 

Analyze -> Regression-> 
Generalized Linear 

Models 

N/A PROC GLIMMIX; 
model count_var= num_var 

/dist=Poisson; 

glm(count_var ~ num_var, 
family=Poisson) 

Generalized linear 
mixed model 

Statistics -> Multilevel mixed-effects models 
-> Generalized linear model 

OR 
meglm var1 var2 || rand_var_eqn, 
family(distribution) link(link_function) 

Analyze-> Mixed 
Models-> Generalized 

Linear 

N/A PROC GLIMMIX; 
class cat_var; 

model num_var1= num_var2 
cat_var rand_var; 
random rand_var; 

Package lme4 
 

Lmer(num_var1~ num_var2 + 
cat_var + (1|rand_var) 

Deploy sheets with quickly available information for statistical methods, 
especially more advanced concepts



Be ready to run multiple models that could fit the data and compare best fit
btb_lmer1 <- lmer(bdi ~ bdi.pre + time + treatment + drug + length + (1 | subject),

data = BtheB_long, REML=FALSE, na.action = na.omit) #Rand Int

btb_lmer2 <- lmer(bdi ~ bdi.pre + time + treatment + drug + length + (time | subject),
data = BtheB_long, REML=FALSE, na.action = na.omit) #Rand Int & Slope

btb_gee1 <- gee(bdi ~ bdi.pre + treatment + length + drug,
data = BtheB_long, id = subject, family = gaussian, corstr = "independence")

btb_gee2 <- gee(bdi ~ bdi.pre + treatment + length + drug,
data = BtheB_long, id = subject, family = gaussian, corstr = "exchangeable")

anova(btb_lmer1, btb_lmer2, btb_gee1, btb_gee2)

PROC GLIMMIX data=DATASET method=RSPL;
class RAND1;
model Y_VAR=X_VAR1 |  X_VAR2;
random RAND1;  



Be ready to run multiple models that could fit the data and compare best fit

reg1 <- lm(Dep ~ Ind1 + Ind2 + Ind3 + Ind4)
sreg1 <- step(reg1, direction=“forward”)
sreg2 <- step(reg1, direction=“backward”)
sreg3 <- step(reg1, direction=“both”)

PROC GLMSELECT data=sashelp.baseball
plots=all;

class league division;
model logSalary = nAtBat nHits nHome nRuns

nRBI nBB yrMajor crAtBat
crHits crHome crRuns crRbi
crBB league division nOuts
nAssts nError
/ details=all stats=all;



Get to know your data through exploratory data visualization (summary 
tables, boxplots, scatter plots, dimensional reduction, etc.)
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Get to know your data through exploratory data visualization (summary 
tables, boxplots, scatter plots, dimensional reduction, etc.)



Answer questions to get you thinking about your data to figure out 
structure and variable information

https://und.qualtrics.com/jfe/form/SV_dcyUSPLhD4cmP5Q

https://und.qualtrics.com/jfe/form/SV_dcyUSPLhD4cmP5Q


Answer questions to get you thinking about your data to figure out 
structure and variable information

https://und.qualtrics.com/jfe/form/SV_dcyUSPLhD4cmP5Q

# Question

1 What is your Y variable?

2 How is your Y variable measured (categorical-> ordinal or nominal, 
numerical -> continuous or discrete)?

3 What are your X variables?

4 How are your X variables measured (categorical-> ordinal or 
nominal, numerical -> continuous or discrete)?

5 Are their major considerations you need to be aware of 
(confounding factors, longitudinal design, missing data, etc.)?

https://und.qualtrics.com/jfe/form/SV_dcyUSPLhD4cmP5Q


Walk through branching decisions to determine appropriate test to use



Walk through branching decisions to determine appropriate test to use



Please take the survey:
Survey: https://und.qualtrics.com/jfe/form/SV_9oWw3jNUcqDL8Gy

Working with a biostatistician your best, but not only, 
option

If you struggle with a busy schedule, analyzing complex 
data, or getting your head around unknown data, there 
are a bundle of strategies to help you survive

Strategies are boilerplate code, flexible models, GUI 
usage, tiering methods, cheat sheets, multiple models, 
visualization first, data questionaries, and decision 
trees

https://und.qualtrics.com/jfe/form/SV_9oWw3jNUcqDL8Gy


Resources

[1] https://www.youtube.com/watch?v=nkkv96teOxs

[2] https://med.und.edu/daccota/_files/docs/berdc_docs/mmgg_r_code.txt

[3] https://www.youtube.com/watch?v=YtmloAwp2rI

[4] https://www.rstudio.com/resources/cheatsheets/

[5] https://med.und.edu/daccota/_files/docs/berdc_docs/statistical_software_toolkit_handout.docx

[6] http://www.ecostat.unical.it/Tarsitano/Didattica/LabStat2/Everitt.pdf

[7] https://www.youtube.com/watch?v=eiivMNBZvw8

[8] https://med.und.edu/daccota/_files/pdfs/berdc_resource_pdfs/stat_decision_tree.pdf

[9] https://www.youtube.com/watch?v=kpmnFMznYt8

[10] https://www.youtube.com/watch?v=YeKXdLFw0YI
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[1] https://d3gqasl9vmjfd8.cloudfront.net/83b73cac-f64d-4f7a-b6a5-78bbc6e6c559.png

[2] https://plotly-book.cpsievert.me/images/plotlyGGally.gif

[4] https://blogs.sas.com/content/graphicallyspeaking/files/2013/03/VBox4.png

[5] https://i.pinimg.com/originals/47/1f/29/471f291ba7a7cd81c2118fe37be00b05.jpg

[6] https://xkcd.com/1195/
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