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Introduction

* There are many statistical software options

* Some are better at some things than others

* At the end of the day, they are all tools to aid you in your research
* It is good to know your way around multiple tools

* Here, we’ll be counting down the top 5 tools for statistical software
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Inclusion Criteria

» Software is free, has a free version, or has a version that can be
accessed through UND for free

e Software I've had at least some experience with
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Overview:

* general-purpose package
created by StataCorp

* 1985

Tool: Rachet wrench
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* Access 1!"‘

| T
* Need Citrix Workspace first i P.
* https://und.teamdynamix.com/TDC _

lient/2048/Portal/KB/ArticleDet?ID [-aw o et e

586 ; ; Keview
X, Filt: ere [ - ™
2 |c o I [ A /
e mm— / [/ /_/ f [__J 1a.2 Copyrignt 1985-2015 StataCorp LLC
1 import delimited "\\Client\... Statistics/Data Analysis
4805
WWWWWW

e Add Stata-64 to the Citrix App

| e at u I e S 44-student Stata lab perpetual license:
Serial number: 301406223919
Licensed to: UND User
Py C UND College of Business
0 l I I l I l a n Notes:
1. TUnicode is supported; see help unicode advice.
) . import delim "\\Client\C§\Users\Mark.Williamson.2\Desktop\Willianson Data\SPSS\SPSS_data\Kokanee.csv"
u OW I I 3 vaze, 2%

* Downside o
* Plug-and-chug problem S —
* Coding learning curve e

Command
impor te C1i C$\Users\Mark.Willianson.2\Desktop\Williamson Data\SPSS\SPSS_data\Rol

Suggested Uses: All purpose data
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Overview: Tool: Power Drill

* Interactive statistical analysis
package created by SPSS Inc. then
acquired by IBM

* 1968 (SPSS Inc.); 2009 (IBM)
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File Edit View Data Transform  Analyze Graphs  Ufiliies  Extensions  Window  Help
== EE e Al
.o / CCitriv A SRe R e~ FLIE A EE 96
C Ce S S . C I t r I X p p | [ |Visible: 5 of 5 variables
| ilagecat " & gender " &> marital " & active ” &> bfast ” var " var " var ” var " var ” var " var " var || var "

Y

* Features
 All pull-down except a few
* In-package data working
* Sample Datasets

* Downsides

* Pain to get data in
* Plug-and-chug

* No coding

[ T Y S U U G R R N U R SN S e R R R S R U R R S JU Ry
[ N L — 1 I— [P U (R Ul i ) S L e i i e ==
o O N N S PN U R ROl o B NS S S (U U U
—ADD—A—AD—L—A—LDDD—A—L—ADDW—LDDDD—ADD—A

[EN TR N T N T P e Y e e W L N o QR T N e e L I S T o S VIR . T N T G S

R

1

Data View VYariable View

3]

H

[IBM SPSS Statistics Processorisready | | [Unicode:OM | [ ]

Suggested Uses: Very Simple or very complex data
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Overview: Tool: Hammer

* Spreadsheet developed by Microsoft
e 1987
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Williamson, Mark

L] L] L]
. AC C e S S [ ] ty p I Ca | | y b u I | t - I n File Home Insert Page Layout Formulas Data Review View Help 1% Share I Comments
¢ fi;* Calibri ST S 25, Wrap Text General . =i @ ﬂf}f & =X b= >~ %? /O g
Pajte g B I U- & A Merge&Center ~ | § « % 9 | 58 08 Fifrl::\tttllnnr;alv F%E;a; Stji~ \nsvert Delvate Fnr'mat o Fsllﬂt:r& SZL‘itBi Ideas
. F t Clipboard Font [ Alignment. (] Number [ Styles Cells Editing Ideas Sensitivity | A
eatures T ; .
A B © D E F G H | J K L M N e} P Q R s T .
. 1 |Islands SpeciesRiiSaspecies endemic percenter Area altitude  elevation distance® distancevi distances distancelargeisland
[ J I nte ra Ctlve S readSheet 2 |Ecuadar 65 57 1 15 3487 3500 2397 1 1 1 1
3 chiles 36 31 1 2.7 326 3500 1264 36 14 36 36
4 |Las Papas-Cocor 20 25 1 3.3 501 3500 1170 234 13 26 26
- 5 Sumapaz 37 32 3 8.1 2031 3500 1060 543 83 80 116
[ ] F u n Ct I O n S 6 Tolima-Quindio 35 33 9 25.7 989 3500 1900 551 23 25 25
7 Paramillo 11 10 1 9 25 3500 460 773 45 45 186
8 |Cocuy 21 18 1 a7 2168 3500 1998 201 14 108 14
9 |Pamplona 11 9 1 9 217 3500 700 950 14 14 14
° 10 |Cachira 13 12 0 o 143 3250 735 958 5 19 19
o D OW n S I d e S 11 |Tama 17 14 0 [ 45 3000 613 995 25 29 29
12 |Batallion 13 10 0 o 66 3250 662 1065 55 65 55
13 |Merida 29 26 6 20.6 1792 3500 1502 1167 35 S5 204
14 Perija 4 4 2 50 167 3000 750 1182 75 197 75
. ] ] 15 |Santa Marta 18 16 12 66.6 606 3500 2275 1238 75 75 330
e Not technicallv statistical S I
17
18 >
ft k w
software package 2@
21
* Basic :
25
26
27
28
29
30
nsular [C] [l
& L& Display Settings ]

Suggested Uses: Data formatting and exploration
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Overview: Tool: Table Saw

* Multi-purpose package developed
by SAS Institute

* 1976
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e Access: SAS Studio

e https://www.sas.com/en us/software/on-

demand-for-academics.htmlFeatures

* Features

* Consistent structure

* Directories

* Sample data

* Colors

* Anticipatory

* Log

* Transforming data
* Great support

* Downsides

* Upload limits

* Not all available in Studio '

SAS

[l Folder Shortcuts
4 L2 Files (Home)
4 my_courses
b [ briandarby0
4 [ markuilliamson0
» I MW_2018_Work
b MW
o MW
» I BRFSS
» [l Covid19
» [ NHANES
[E4 Cancer Paper 1 Rates by Year v2.sas
[£ Cancer Paper 1 Rate

[£3 Cancer Paper 1 Sophisticated County Model.sas

9?_Work

0_Work

Yearsas

[£3 Cancer Paper 2 Alternative.sas
[§2 Cancer Paper 2 Work.sas

[£4 Cancer Paper 2a map experimental.sas
[£ Cancer Paper 2a map.sas

[£3 Cancer Paper 2a.cas

[E2 Cancer Paper 2b.sas

[§2 Cancer Paper Combined.sas

[#2 County Cancer Rate Categories and Health Centers.sas
[£3 Exploratory Data Analysis Il examples.cas

[£3 Fich Example.cas

[i2 GLM for Cancer Paper 2.5as

[£2 GLMM in R Example Distributions.sas

[£2 Lymphoma Test.sas

[ MW_head_back.sas

[ ND Cancer Analy

» Tasks and Utilities

» Snippets

ries

SAS® Studio

~ Server Files and Folders [£ Cancer Paper 1 Rates by Yearv2.sas %

- @ & F B O {CobE LoG RESULTS

468 odaws01-usw? 2 O- HR B B & »a % i ® % =

*PART 1: Open File;

PROC IMPORT datafile='/home/markwilliamson20/my_courses/markwilliamson@/Mi_Datasets 2020/US and ND all.csv'

dbms=csv out=Cancer replace;
getnames=yes;

b

*PART 2: Combined Cancer Plots: Lung, Colorectal, Melanoma, and Bladder;
PROC SORT dsta=Cancer;

by Year;
PROC PRINT data=Cancer;

0DS LISTING STYLE = JOURNAL;
PROC SGPLOT data=Cancer;
where Cancer="Lung&Bronchus" and Gender="Combined";
title "Combined Lung&Bronchus";
scatter y=Rate x=Year /group=Region markerattrs=(symbol=CircleFilled)
yerrorlower=LCI yerrorupper=UcI;
series y=Rate x=Year /group=Region;
label Rate="Incidence Rate (per 1€0,000)";
xaxis values=(200@, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009,
2010, 2011, 2012, 2013, 2014, 2015, 2016);
yaxis values=(e, 5, 1e, 15, 2@, 25, 3@, 35, 4@, 45, 50, 55, €@, €5, 7@, 75);

PROC SGPLOT data=Cancer;

where Cancer="Colorectal” and Gender="Combined";

title "Combined Colorectal";

scatter y=Rate x=Year /group=Region markerattrs=(symbol=CircleFilled)
yerrorlower=LCI yerrorupper=UCI;

series y=Rate x=Year /group=Region;

label Rate="Incidence Rate (per 100,000)";

xaxis values=(2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009,
2010, 2011, 2012, 2013, 2014, 2015, 2016);

yaxis values=(e, 5, 1@, 15, 2@, 25, 3@, 35, 4@, 45, 50, 55, €@, 65, 7@, 75);

PROC SGPLOT dat: ancer;
where Cancer="Melanoma" and Gender="Combined";
title "Combined Melanoma";
scatter y=Rate x=Year /group=Region markerattrs=(symbol=CircleFilled)
yerrorlower=LCI yerrorupper=UCT;
series y=Rate x=Year /group=Region;

20/my._ will /_2020_Work/Cancer Paper 1 Rates by Year v2.sas

000

SAS Programmer

(D Messeoss

Suggested Uses: All purpose data

8 @ sonou

User: markwillismson20
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Honorable Mentions ™™

NORTH DAKOTA.

Wolfram

.. . Mathematica
m Minitab *

‘MathWorksca A pgthon”

Q y
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Overview: Tool: Swiss-army knife made of Swiss-
* Programming language and software army knives
environment developed by the R Core
Team

* 1993
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* Access: Citrix App or — g

File Edit Code View Plots Session Build Debug Profile Tools Help

direct download S

9| Exploratory Data Analysis Ill examplesR —["]  Environment History ~Connections =

(https-//c ran.r- Souceonsme | Q J - i | 4| Hosouce -| = | | @ b | oconse | S Tosouce |0 &
L] L] -

#PART 1: Setup

1
2
. 3
r r 4 setwd("C:/users/mark.williamson.2/Desktop/willliamson Presentations/statistical Modules")
° 5 Tibrary(ggplot2)
6
8
9

~ Addins ~ R project: (None) ~

Tibrary(dplyr)
Tibrary(rgl)
o I eatu res 10 #PART 2: Bubble Plot
11
12 #iris

13 head(iris)

.
14
L4 ( OI I Il I la nd Ilne 15 ggplot(data=iris, aes(x=Sepal.Length, y=Sepal.width, size=Petal.Length))+

16 geom_point(alpha=0.
17 ggplot(data=iris, aes(x=Sepal.Length, y=Sepal.width, size=Petal.Length, color=Species))+

18 geom_point(alpha=0.7)
L] CO m m a n e r 19 Files Plots Packages Help Viewer
20 #insular TS
21 dinsular<-read.csv("insular.csv") = Bxport
. 22 attach(insular)
[ ) R Stud IO 23 print(insular)
24
25 ggplot(data=insular, aes(x=Area ,y=elevation, size=SpeciesRichness)) + "
2R asom naint(alnha=0 7)
12:6 ntitled) ript ¢
* Packages and support =
Console ~ Terminal Jobs =]
Copyright (C) 2019 The R Foundation for statistical cComputing -

.
. D OW n S I d e S Platform: x86_64-w64-mingw32/x64 (64-bit)
R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'Ticense()' or 'licence()' for distribution details.

.
* Learning curve
Natural language support but running in an english locale

. R is a collaborative project with many contributors. I
() Type 'contributors()' for more information and

O S a n a r IZe "citation()' on how to cite R or R packages in publications.
Type 'demo()' for some demos, "help()' for on-Tline help, or

.
n Otat|0 n ‘help.start()' for an HTML browser interface to help.
Type 'q()" to quit R.

[workspace loaded from ~/.RData]

>

Suggested Uses: All purpose data and weird stuff



https://cran.r-project.org/

DaCCoTL LN;D
DAKOTA CANCER COLLABORATIVE ‘

ON TRANSLATIONALACTIVITY e U NV ERS T Y OF
Example

NORTH DAKOTA.

Kokanee Fish

* 298 observations

* Length and weight of salmon

* Male and female (will not use)
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Summary Handout roerith

* Available online at https://med.und.edu/daccota/berdc-resources.html

e Under Special Topics Talks -> The Statistical Software Toolkit

General Info

STATA

SPSS Excel

SAS

R

STATA

https://www.stata.com/links/resources-for-learning-stata/
*  https://data.princeton edu/stata/

*  https://dsc gmu_eduffiles/Advanced_stata_Skills pdf

o https:/fwww.stat:

ts.pdf

o https://www.spss-tutorials.com/basics/

o statisticshowto.ce

. hu.ac.uk/l

_data_using_spss.pdf

*  https://rslblissett.com/resources/spss_cheat_sheet/

XCEL
o htp: excel-easy.com/d Ipak htm!
o http: excel-easy.com/d ysis/charts. htm!
s https://edu.gcfglobal.org/en/excel2016/functions/1/
o http: ide.com/c el-cheat-sheet. pdf
$AS
o https://d ion.sas.com/? ersion=9.4_3.3&
o https://www tutorialspoint.com;/sas/index.htm
* listendata.com/p/sas-tuterials html
®  https://sites.ualberta.ca/~ahamann/teaching/renrd80/5A5-Cheat.pdf
R

+  statmethods net/r-tutorial findex htm|
+  https://www.tutorialspoint.com/r/index.htm

o hitps: github.

lied_statistics.pdf

o https://)

jio.com fwp-c

2016/10fr-cheat-sh pdf

Access Citrix Workspace > Citrix Workspace -> (installed on most 5AS website -> On demand for | https://cran.r-project.org
Stata-64 app SPSS Statistics 26 app academics -> $AS Studio hittps://1 com,
Features Command line; drop-down menus; user- Drop-down menus; Interactive Within-software code sheet; | Command line; R commander;
written programs data ; functions; | consistent structure; high R Studio; additional packages
spreadsheet add-on ionali support
Resources

. htmE&locale=en

E pl STATA SPSS Excel SAS R
Summary statistics | Data->Describe Data-> Summary Statistics Analyze -» Descriptive AVERAGE(num._ var) PROC UNIVARIATE: summarylpum. yar)
Statistics -> Descriptives | =MEDIAN(num_var) var pum_var;
summarize num. yar. =STDEV.S{num. var) -
Histogram Graphics-> Histogram Graphs -> Chart Builder - | Insert (Charts)-> PROC SGPLOT: hist(num._var)
OR > Histogram Histogram histogram num_var;
histogram qum_var
Boxplat Graphics-> Box plot Graphs -> Chart Builder - | Insert (Charts)-> Box PROC SGPLOT: plotlpum,_yar=cat var)
OR > Boxplot and Whisker
graph box pum_var, over(cat var) group=cat_var;
Bar plot Graphics-> Bar Chart Graphs -> Chart Builder - | Insert (Charts)-> PROC SGPLOT, means <- clmean_cat1,
> Bar Column category=cat.var, | mean_cat2)
graph bar (mean) gum_var, overleat, var) treatment=num_mean
Scatterplot Graphics -> Tyguay. graph Graphs -> Chart Builder - | Insert (Charts)-> PROC SGPLOT, plotloum_var, num_varz2)

OR > Scatter/Dot Scatter Scatter y=num_vari
fwoway (scatter num_varl num_var2) x=num_var2;
T-test ‘Statistics > Summaries, tables, and tests > | Analyze -» Compare =LIEST({num_vart, PROC TTESH: ttestinum_varscat var)
Classical tests of hypotheses -> t tests means-> Independent- num_var2, tails, type) | var num_ver;
OR Samples T Test class gt var,
ttestaum var. by(cat var)
ANOVA Statistics-> Linear models and related - Analyze -> Compare Data Analysis (add-on) - | PROC ANOVA; aeylnum_var-cat_var)

ANOVA/MANOVA -> One-way ANOVA
OR
QNEwEY num_var cat_var

means-> One-Way
ANOVA

> Anova: Single Factor

class gat_var.

medel gum_yar=eal var

Normal linear
regression model

Statistics-> Linear models and related -
Linear regression

OR
regress num_vard num_var2

Analyze -» Regression->
Linear

Data Analysis (add-on) -
> Regression

PROC REG.

model num_var1= num_var2;

Im{num_vart ~num_var2)

Logistic regression | Statistics-» Binary outcomes—> Logistic Analyze -» Regression-> | N/A PROC LOGISTIC; elmlbinany. var ~ oum. e,
model regressien Binary Logistic model i iniomi
OR num_var2;
logit hingry. varnum. var
Poisson regression | Statistics -» Count outcomes-> Poisson Analyze -> Regression-> | N/A PROC GLIMMIX; ~
model regression Generalized Linear model count ¥or= num.var | family=Poisson)
OR Madels /dist=Poisson;
Poisson count. var num var
Generalized linear | Statistics -> Multilevel mixed-effects models | Analyze-> Mixed N/A PROC GLIMMIX; Package Imed.

mixed model

~» Generalized linear model
OR
mselm.vart var2 | |

link(fink_function)

Models-> Generalized
Linear

class gat_var,
model num_vart= num_var2

sab.yar cand.vae
random rgnd_var,

Lmerlnum_vart™ num_var2 +
cat.yar + (1|rand_var)
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